大智慧公式

大智慧彩带空调主图指标公式

N:=8;
DRAWTEXTREL(4,40,’板块:’+BKNAME),COLOR00FF00,linethick1;
DRAWTEXTABS(4,29 ,’流通盘:’+capital/1000000+’亿(小盘股<5个亿<中盘股<10亿<大盘股)’),COLOR00FF00,linethick1;
{N:5,30,13;参数N,短线选8,中线选13,长线选21;}
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
MA120:=MA(CLOSE,120);
{彩带}
FILLRGN(MA60,MA120,MA60>MA120,RGB(86,0,0),MA60<MA120,RGB(0,86,0)),LAYER7;
FILLRGN(MA5,MA10,MA5>MA10,RGB(128,0,128),MA5<MA10,RGB(20,92,100)),LAYER7;
高山:HHV(MA(H,N),N),COLORRED,LINETHICK2;
流水:MA(H,N),COLORFFFFFF,LINETHICK2;
出水:=IF(C>HHV(MA(H,N),8) AND HHV(MA(H,N),8)>MA(H,N),1,0);
回踩:=IF((CROSS(MA(H,N),L) OR CROSS(MA(H,N)*1.01,C))AND BARSLAST(出水)<=5,1,0);
STICKLINE(出水,(C+O)/2,(C+O)/2,3,0),COLORFF00FF;
STICKLINE(出水,H,L,0,0),COLORFF00FF;
DRAWTEXT(回踩,L, ‘↑’),COLORFFFFFF;
HHV(流水,2),COLOR00FF00;
HHV(流水,3),COLOR00FF00;
HHV(流水,4),COLOR00FF00;
HHV(流水,5),COLOR00FF00;
HHV(流水,6),COLOR00FF00;
HHV(流水,7),COLOR00FF00;
HHV(流水,8),COLOR00FF00;
HHV(MA(H,N),N),COLORRED,LINETHICK2;
空:=EMA(C,5);
均衡:=EMA(空,5);
中轨:=HHV(MA(H,13),13);
趋势:=LLV(MA(H,13),1);
var1r:=(HIGH+LOW+OPEN+2*CLOSE)/5;
var2r:=REF(var1r,1);
var3r:=SMA(MAX(var1r-var2r,0),10,1)/SMA(ABS(var1r-var2r),10,1)*100;
var4r:=FILTER(IF(COUNT(var3r<20,5)>=1 AND COUNT(var1r=LLV(var1r,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
DRAWICON(var4r,LOW,1);
var5r:=FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11);
DRAWTEXT(var5r,Low*0.985,’加仓’),COLORyellow;
DRAWTEXT(var5r,Low*0.995,’^’ ),COLORyellow;
var6r:=REF(CLOSE,1);
var7r:=SMA(MAX(CLOSE-var6r,0),6,1)/SMA(ABS(CLOSE-var6r),6,1)*100;
DRAWTEXT(CROSS(84,var7r),H*1.035,’减仓’),COLOR00FF00 ;
DRAWTEXT(CROSS(84,var7r),H*1.015,’◇’ ),COLOR00FF00;

大智慧彩带空调主图指标公式

 

Originally posted 2018-01-22 13:04:55.